Platform data processing delays

Incident Report for Rand Platform

Resolved

Rand McNally engineering has monitored the system and all devices are presently pinging into the platform in real time. We are setting the status to resolved and further investigation will be performed into the root cause to prevent any future interruptions. Should you need further assistance please submit a ticket with our support team in regards to this matter for further review.
Posted Apr 17, 2025 - 19:47 UTC

Monitoring

Rand McNally engineering has reported that they have fixed the issue causing the platform delays and all devices should be pinging into the platform now in real time. We will continue to monitor the platform for a period of time. We apologize for any inconvenience during this time and will update the status to resolved after performing some final checks.
Posted Apr 17, 2025 - 16:49 UTC

Update

Rand McNally engineering has identified and performed some remediation actions to resolve the issue. We are continuing to work on this issue and we are seeing improvements with real time updates coming into the platform from devices in the field. We will continue to notify through the status page with updates.
Posted Apr 17, 2025 - 16:09 UTC

Identified

We are aware of platform processing delays, which are causing Asset location and data delays in the platform for many devices globally. We are actively investigating this issue and will provide further updates as we have them.

Our team has identified the cause of the data processing issue are are taking remediation actions to resolve the issue. We expect to start seeing improvements in data processing shortly and Asset delays starting to reduce.
Posted Apr 17, 2025 - 13:50 UTC
This incident affected: Data Processing.