Groups Management Module

Incident Report for Rand Platform

Resolved

The Groups Management Module is behaving as expected.
Posted Jun 18, 2025 - 20:27 UTC

Monitoring

A fix has been implemented, and the Groups module is working as expected. We will continue to monitor the other Groups-related functionality for the next 24-48 hours.
Posted Jun 10, 2025 - 22:18 UTC

Investigating

We are currently investigating an outage affecting the Groups Management module on the Platform. This module is accessible via the Kebab Menu (three vertical dots) in the top right corner. Users attempting to access it may encounter an error message.

In addition, this issue may impact related functionality tied to Groups, including:

Filtering by Group(s) on the Fleetmap

Workflow automations and alerts involving Groups

Driver assignment and Asset visibility where either entity is associated with a Group

Our engineering team is actively working to identify the root cause and restore full functionality as quickly as possible.

We apologize for the disruption and appreciate your patience. We will provide updates as we learn more. If you have any questions, please contact our support team
Posted Jun 10, 2025 - 20:26 UTC
This incident affected: Web Application and Mobile Applications.