Site Access Interruption
Incident Report for Rand Platform
Resolved
This incident has been resolved.
Posted Jul 18, 2024 - 14:38 UTC
Monitoring
We have implemented a fix and are currently monitoring the results. The web application is now accessible, you may experience minor delays during login.
Posted Jul 18, 2024 - 13:21 UTC
Identified
The issue has been identified and we are currently working to restore services.
Posted Jul 18, 2024 - 11:52 UTC
Investigating
We are currently experiencing an issue that is preventing access to our website and displaying an error message. Our team is working diligently to resolve this as quickly as possible. We will provide updates shortly as we work to restore the service.
Posted Jul 18, 2024 - 10:49 UTC
This incident affected: Web Application.